OpenBSD manual page server

Manual Page Search Parameters

USB(4) Device Drivers Manual USB(4)

usbintroduction to Universal Serial Bus support

# zaurus specific
ohci0 at pxaip?
# all architectures
ehci* at cardbus?
uhci* at cardbus?
ohci* at cardbus?
ehci* at pci?
uhci* at pci?
ohci* at pci?
usb* at ehci? flags 0x00
usb* at uhci? flags 0x00
usb* at ohci? flags 0x00
uhub* at usb?
uhub* at uhub?


option USBVERBOSE


#include <dev/usb/usb.h>
#include <dev/usb/usbhid.h>

OpenBSD provides machine-independent bus support and drivers for Universal Serial Bus (USB) devices.

The OpenBSD usb driver has three layers (like scsi(4) and pcmcia(4)): the controller, the bus, and the device layer. The controller attaches to a physical bus (like pci(4) or cardbus(4)). The USB bus attaches to the controller and the root hub attaches to the USB bus. Devices, which may include further hubs, attach to the root hub. The attachment forms the same tree structure as the physical USB device tree. For each USB device there may be additional drivers attached to it.

The uhub driver controls USB hubs and must always be present since there is at least one root hub in any USB system.

The flags are used to specify if the devices on the USB bus should be probed early in the boot process. If the flags are specified with a value of 1, the USB bus will be probed when the USB host device is attached instead of waiting until kernel processes start running.

OpenBSD provides support for the following devices. Note that not all architectures support all devices.

umass(4)
USB Mass Storage Devices, e.g., external disk drives

aue(4)
ADMtek AN986/ADM8511 Pegasus family 10/100 USB Ethernet device
axe(4)
ASIX Electronics AX88172/AX88178/AX88772 10/100/Gigabit USB Ethernet device
cdce(4)
USB Communication Device Class Ethernet device
cue(4)
CATC USB-EL1201A USB Ethernet device
kue(4)
Kawasaki LSI KL5KUSB101B USB Ethernet device
mos(4)
MOSCHIP MCS7730/7830 10/100 USB 2.0 Ethernet device
udav(4)
Davicom DM9601 10/100 USB Ethernet device
ueagle(4)
Analog Devices Eagle ADSL modems
url(4)
Realtek RTL8150L 10/100 USB Ethernet device
urndis(4)
USB Remote NDIS Ethernet device

athn(4)
Atheros IEEE 802.11a/g/n wireless network device
atu(4)
Atmel AT76C50x IEEE 802.11b wireless network device
otus(4)
Atheros USB IEEE 802.11a/g/n wireless network device
rsu(4)
Realtek RTL8188SU/RTL8192SU USB IEEE 802.11b/g/n wireless network device
rum(4)
Ralink Technology USB IEEE 802.11a/b/g wireless network device
run(4)
Ralink Technology USB IEEE 802.11a/g/n wireless network device
uath(4)
Atheros USB IEEE 802.11a/b/g wireless network device
ubt(4)
Bluetooth adapters
upgt(4)
Conexant/Intersil PrismGT SoftMAC USB IEEE 802.11b/g wireless network device
ural(4)
Ralink Technology USB IEEE 802.11b/g wireless network device
urtw(4)
Realtek RTL8187L/RTL8187B USB IEEE 802.11b/g wireless network device
urtwn(4)
Realtek RTL8188CU/RTL8192CU USB IEEE 802.11b/g/n wireless network device
wi(4)
Intersil PRISM 2-3 IEEE 802.11b wireless network device
zyd(4)
ZyDAS ZD1211/ZD1211B USB IEEE 802.11b/g wireless network device

moscom(4)
MosChip Semiconductor MCS7703 based USB serial adapter
uark(4)
Arkmicro Technologies ARK3116 based USB serial adapter
ubsa(4)
Belkin USB serial adapter
uchcom(4)
WinChipHead CH341/340 based USB serial adapter
ucom(4)
USB tty support
uftdi(4)
FTDI USB serial adapter
uipaq(4)
iPAQ USB units
ulpt(4)
USB printer support
umct(4)
MCT USB-RS232 USB serial adapter
umodem(4)
USB modem support
umsm(4)
Qualcomm MSM modem device
uplcom(4)
Prolific PL-2303 USB serial adapter
uslcom(4)
Silicon Laboratories CP2101/CP2102 based USB serial adapter
uticom(4)
Texas Instruments TUSB3410 USB serial adapter
uvisor(4)
USB Handspring Visor
uvscom(4)
SUNTAC Slipper U VS-10U USB serial adapter

uaudio(4)
USB audio devices
umidi(4)
USB MIDI devices
urio(4)
Diamond Multimedia Rio MP3 players

udl(4)
DisplayLink DL-120 / DL-160 USB display devices
uvideo(4)
USB video devices

udcf(4)
Gude ADS Expert mouseCLOCK USB timedelta sensor
umbg(4)
Meinberg Funkuhren USB5131 timedelta sensor

udsbr(4)
D-Link DSB-R100 USB radio device

tpms(4)
Apple touchpad mouse
ucycom(4)
Cypress microcontroller based USB serial adapter
uhid(4)
Generic driver for Human Interface Devices
uhidev(4)
Base driver for all Human Interface Devices
uhts(4)
USB HID touchscreen support
ukbd(4)
USB keyboards that follow the boot protocol
ums(4)
USB mouse devices
uthum(4)
TEMPer USB temperature and humidity sensor
utrh(4)
USBRH temperature and humidity sensor

uberry(4)
Research In Motion Blackberry
ugen(4)
USB generic device support
uow(4)
Maxim/Dallas DS2490 USB 1-Wire adapter
upl(4)
Prolific based host-to-host adapters
uscanner(4)
USB scanner support
usps(4)
USPS composite AC power and temperature sensor
uts(4)
USB touchscreen support
uyap(4)
USB YAP phone firmware loader

There are different versions of the USB which provide different speeds. USB 2 operates at 480Mb/s, while USB versions 1 and 1.1 operate at 12 Mb/s and 1.5 Mb/s for low speed devices. Each USB has a host controller that is the master of the bus; all other devices on the bus only speak when spoken to.

There can be up to 127 devices (apart from the host controller) on a bus, each with its own address. The addresses are assigned dynamically by the host when each device is attached to the bus.

Within each device there can be up to 16 endpoints. Each endpoint is individually addressed and the addresses are static. Each of these endpoints will communicate in one of four different modes: control, isochronous, bulk, or interrupt. A device always has at least one endpoint. This is a control endpoint at address 0 and is used to give commands to the device and extract basic data, such as descriptors, from the device. Each endpoint, except the control endpoint, is unidirectional.

The endpoints in a device are grouped into interfaces. An interface is a logical unit within a device; e.g., a compound device with both a keyboard and a trackball would present one interface for each. An interface can sometimes be set into different modes, called alternate settings, which affects how it operates. Different alternate settings can have different endpoints within it.

A device may operate in different configurations. Depending on the configuration the device may present different sets of endpoints and interfaces.

Each device located on a hub has several config(8) locators:

port
Number of the port on closest upstream hub.
configuration
Configuration the device must be in for this driver to attach. This locator does not set the configuration; it is iterated by the bus enumeration.
interface
Interface number within a device that an interface driver attaches to.
vendor
16-bit vendor ID of the device.
product
16-bit product ID of the device.
release
16-bit release (revision) number of the device.

The first locator can be used to pin down a particular device according to its physical position in the device tree. The last three locators can be used to pin down a particular device according to what device it actually is.

The bus enumeration of the USB bus proceeds in several steps:

  1. Any device-specific driver can attach to the device.
  2. If none is found, any device class specific driver can attach.
  3. If none is found, all configurations are iterated over. For each configuration all the interfaces are iterated over and interface drivers can attach. If any interface driver attached in a certain configuration, the iteration over configurations is stopped.
  4. If still no drivers have been found, the generic USB driver can attach.

Use the following to get access to the USB specific structures and defines:

#include <dev/usb/usb.h>

The /dev/usbN device can be opened and a few operations can be performed on it. The poll(2) system call will say that I/O is possible on the controller device when a USB device has been connected or disconnected to the bus.

The following ioctl(2) commands are supported on the controller device:

struct usb_device_info *
This command can be used to retrieve some information about a device on the bus. The udi_addr field should be filled before the call and the other fields will be filled by information about the device on that address. Should no such device exist, an error is reported.
#define USB_MAX_DEVNAMES 4
#define USB_MAX_DEVNAMELEN 16
struct usb_device_info {
	u_int8_t	udi_bus;
	u_int8_t	udi_addr;	/* device address */
	usb_event_cookie_t udi_cookie;
	char		udi_product[USB_MAX_STRING_LEN];
	char		udi_vendor[USB_MAX_STRING_LEN];
	char		udi_release[8];
	u_int16_t	udi_productNo;
	u_int16_t	udi_vendorNo;
	u_int16_t	udi_releaseNo;
	u_int8_t	udi_class;
	u_int8_t	udi_subclass;
	u_int8_t	udi_protocol;
	u_int8_t	udi_config;
	u_int8_t	udi_speed;
#define USB_SPEED_LOW  1
#define USB_SPEED_FULL 2
#define USB_SPEED_HIGH 3
	int		udi_power;	/* power consumption */
	int		udi_nports;
	char		udi_devnames[USB_MAX_DEVNAMES]
			    [USB_MAX_DEVNAMELEN];
	u_int8_t	udi_ports[16];	/* hub only */
#define USB_PORT_ENABLED 0xff
#define USB_PORT_SUSPENDED 0xfe
#define USB_PORT_POWERED 0xfd
#define USB_PORT_DISABLED 0xfc
};

The udi_bus field contains the device unit number of the device.

The udi_product, udi_vendor, and udi_release fields contain self-explanatory descriptions of the device. The udi_productNo, udi_vendorNo, and udi_releaseNo fields contain numeric identifiers for the device.

The udi_class and udi_subclass fields contain the device class and subclass.

The udi_config field shows the current configuration of the device.

The udi_protocol field contains the device protocol as given from the device.

The udi_speed field contains the speed of the device.

The udi_power field shows the power consumption in milli-amps drawn at 5 volts or is zero if the device is self powered.

The udi_devnames field contains the names and instance numbers of the device drivers for the devices attached to this device.

If the device is a hub, the udi_nports field is non-zero and the udi_ports field contains the addresses of the connected devices. If no device is connected to a port, one of the USB_PORT_* values indicates its status.

struct usb_device_stats *
This command retrieves statistics about the controller.
struct usb_device_stats {
	u_long	uds_requests[4];
};

The uds_requests field is indexed by the transfer kind, i.e. UE_*, and indicates how many transfers of each kind have been completed by the controller.

struct usb_ctl_request *
This command can be used to execute arbitrary requests on the control pipe. This is and should be used with great care since it can destroy the bus integrity.

The usb_ctl_request structure has the following definition:

typedef struct {
        uByte           bmRequestType;
        uByte           bRequest;
        uWord           wValue;
        uWord           wIndex;
        uWord           wLength;
} __packed usb_device_request_t;

struct usb_ctl_request {
	int	ucr_addr;
	usb_device_request_t ucr_request;
	void	*ucr_data;
	int	ucr_flags;
#define USBD_SHORT_XFER_OK 0x04	/* allow short reads */
	int	ucr_actlen;	/* actual length transferred */
};

The ucr_addr field identifies the device on which to perform the request. The ucr_request field identifies parameters of the request, such as length and type. The ucr_data field contains the location where data will be read from or written to. The ucr_flags field specifies options for the request, and the ucr_actlen field contains the actual length transferred as the result of the request.

The include file ⟨dev/usb/usb.h⟩ contains definitions for the types used by the various ioctl(2) calls. The naming convention of the fields for the various USB descriptors exactly follows the naming in the USB specification. Byte sized fields can be accessed directly, but word (16-bit) sized fields must be accessed by the (field) and (field, value) macros and double word (32-bit) sized fields must be accessed by the (field) and (field, value) macros to handle byte order and alignment properly.

The include file ⟨dev/usb/usbhid.h⟩ similarly contains the definitions for Human Interface Devices (HID).

usbhidaction(1), usbhidctl(1), ioctl(2), ehci(4), ohci(4), uhci(4), config(8), usbdevs(8)

The USB specifications can be found at:

http://www.usb.org/developers/docs/

The usb driver appeared in OpenBSD 2.6.

September 16, 2011 OpenBSD-5.1