|INTRO(8)||System Manager's Manual||INTRO(8)|
introduction to system maintenance and operation
The manual pages in section 8 contain information related to system operation and maintenance. They describe commands concerning file systems, such as edquota(8), fsck(8), mount(8), and newfs(8). They also cover commands concerning system backup/recovery, such as dump(8) and restore(8).
There are pages which document the running of the system, such as afterboot(8), ifconfig(8), security(8), and the configuration files located in /etc. Procedures concerning system failure are documented in crash(8).
Section 8 pages also describe network services and daemons. The rest of this page discusses some of the main daemons available on the OpenBSD system, and how to enable/disable them.
Thus it is not started by default. To enable or disable daemon processes, administrators should edit the file rc.conf.local(8) or use the rcctl(8) utility. The rc.conf.local(8) file overrides variable assignments in rc.conf(8). So to enable httpd(8), the following line might be added to /etc/rc.conf.local:
As can be seen above, this method is also used to specify additional options.
Below is a list of some of the daemons available. For further information, see rc(8) and the individual pages for the utilities.
If using the amd(8) daemon, go into the /etc/amd directory and set it up by renaming master.sample to master and editing it and creating other maps as needed. Alternatively, you can get your maps with YP.
Relevant rc.conf(8) variables: amd_flags and amd_master.
If you are using a name server, check the /etc/resolv.conf file. It may look something like:
domain nts.umn.edu nameserver 184.108.40.206 nameserver 220.127.116.11 search nts.umn.edu. umn.edu. lookup file bind
If using a caching name server, add the line "nameserver 127.0.0.1" first.
Relevant rc.conf(8) variables: nsd_flags and unbound_flags.
Relevant rc.conf(8) variables: ntpd_flags.
If this is a BOOTP or DHCP server, edit /etc/dhcpd.conf as needed. See also diskless(8).
Relevant rc.conf(8) variables: bootparamd_flags, dhcpd_flags, and dhcrelay_flags.
Edit /etc/rbootd.conf if needed for remote booting. If you do not have HP computers doing remote booting, do not enable this. See also diskless(8).
Relevant rc.conf(8) variables: rbootd_flags.
Relevant rc.conf(8) variables: httpd_flags.
If this is an NFS server, edit /etc/exports.
Relevant rc.conf(8) variables: mountd_flags and nfsd_flags.
A relay daemon, relayd(8), able to run as a load-balancer, application layer gateway, or transparent proxy.
Relevant rc.conf(8) variables: relayd_flags.
Relevant rc.conf(8) variables: bgpd_flags, eigrpd_flags, ospfd_flags, and ripd_flags.
Several services depend on the RPC portmapper, portmap(8), being running for proper operation. This includes YP and NFS exports, among other services.
Relevant rc.conf(8) variables: portmap_flags.
Check the YP domain name with the domainname(1) command. If necessary, correct it by editing the /etc/defaultdomain file (see defaultdomain(5)). The /etc/netstart script reads this file on boot to determine and set the domain name. You may also set the running system's domain name with the domainname(1) command.
Relevant rc.conf(8) variables: ypbind_flags.
In particular, to enable YP passwd support, you'll need to add the following line to /etc/master.passwd:
You do this by using vipw(8).
There are many more YP man pages available to help you. You can find more information by starting with yp(8).
intro manual for section 8 appeared in
|May 26, 2019||OpenBSD-current|