|AMD(8)||System Manager's Manual||AMD(8)|
automatically mount file systems
amd is a daemon that automatically mounts
filesystems whenever a file or directory within that filesystem is accessed.
Filesystems are automatically unmounted when they appear to be
amd operates by attaching itself as an NFS
server to each of the specified directories. Lookups
within the specified directories are handled by
which uses the map defined by mapname to determine how
to resolve the lookup. Generally, this will be a host name, some filesystem
information and some mount options for the given filesystem.
The options are as follows:
-D is only used for debugging,
other options are not documented here: the current supported set of
options is listed by the
-v option and a fuller
description is available in the program source.
amdto standard output where it can be saved into a file.
amdwill scan the mount file table to determine which filesystems are currently mounted. Whenever one of these would have been auto-mounted,
J-S. Pendry and N. Williams, Amd — The 4.4 BSD Automounter, 4.4BSD System Manager's Manual (SMM).
amd utility first appeared in
Jan-Simon Pendry <email@example.com>, Department of Computing, Imperial College, London, UK.
Some care may be required when creating a mount map.
Symbolic links on an NFS filesystem can be incredibly inefficient. In most implementations of NFS, their interpolations are not cached by the kernel and each time a symbolic link is encountered during a lookuppn translation it costs an RPC call to the NFS server. A large improvement in real-time performance could be gained by adding a cache somewhere. Replacing symlink(2) with a suitable incarnation of the auto-mounter results in a large real-time speedup, but also causes a large number of process context switches.
A weird imagination is most useful to gain full advantage of all the features.
|March 8, 2021||OpenBSD-current|