|FSCK(8)||System Manager's Manual||FSCK(8)|
fsck — file system
consistency check and interactive repair
fsck command invokes
file-system-specific programs to check the special devices listed in the
fstab(5) file or on the command line for
It is normally used in the script
rc(8) during automatic reboot. If no file
systems are specified,
fsck reads the file
fstab(5) to determine which file systems
to check and in what order. Only partitions in fstab that are mounted
“rw” or “ro” and that have non-zero pass numbers
are checked. File systems with pass number 1 (normally just the root file
system) are checked one at a time. When pass 1 completes, all remaining file
systems are checked, with one process spawned per disk drive. The disk drive
containing each file system is inferred from the longest prefix of the
device name that ends in a digit; the remaining characters are assumed to be
the partition designator. By default, file systems which are already mounted
read/write are not checked.
The options are as follows:
fsckto use the specified block as the location of the superblock. Block 32 is usually an alternate super block. This option is only valid for filesystems that support backup superblocks (ffs and ext2fs).
fsckis compiled to support it.
fsckexcept for “CONTINUE?”, which is assumed to be affirmative. File systems will not be opened for writing. This is the default for file systems to be checked that are concurrently mounted writable.
fsckwill check all file systems listed in fstab(5) according to their pass number, or any special devices listed on the command line, and will make minor repairs without human intervention. Any major problems will cause
fsckto exit with a non-zero exit code, so as to alert any invoking program or script that human intervention is required.
fsckonly for the comma separated list of file system types. If the list starts with “no”, invoke
fsckonly in the file system types that are not specified in the list.
fsckto assume “yes” as the answer to all operator questions.
If neither of the
-n options are specified, the user may force
fsck to assume an answer of “yes” to
all the remaining questions by replying to a question with a value of
|July 13, 2014||OpenBSD-current|