|NTPD(8)||System Manager's Manual||NTPD(8)|
ntpddaemon synchronizes the local clock to one or more remote NTP servers or local timedelta sensors.
ntpdcan also act as an NTP server itself, redistributing the local time. It implements the Simple Network Time Protocol version 4, as described in RFC 2030, and the Network Time Protocol version 3, as described in RFC 1305.
The options are as follows:
ntpdwill run in the foreground and log to stderr.
ntpdwill stay in the foreground for up to 15 seconds waiting for one of the configured NTP servers to reply.
ntpdto send DEBUG priority messages to syslog.
ntpd uses the
adjtime(2) system call to
correct the local system time without causing time jumps. Adjustments of
32ms and greater are logged using
syslog(3). The threshold
value is chosen to avoid having local clock drift thrash the log files.
ntpd be started with the
-v option, all calls
to adjtime(2) will be
After the local clock is synchronized,
ntpd adjusts the clock frequency using the
adjfreq(2) system call to
compensate for systematic drift.
ntpd starts up, it reads settings
from its configuration file, typically
ntpd.conf(5), and its
initial clock drift from /var/db/ntpd.drift. Clock
drift is periodically written to the drift file thereafter.
ntpd receives a
SIGINFO signal, it writes its peer and sensor status
Network Time Protocol (Version 3), RFC 1305, March 1992.
Simple Network Time Protocol (SNTP) Version 4, RFC 2030, October 1996.
ntpdprogram first appeared in OpenBSD 3.6.
|September 17, 2011||OpenBSD-5.1|