|RC.CONF(8)||System Manager's Manual||RC.CONF(8)|
It is advisable to leave the /etc/rc.conf file untouched, and instead create and edit a new /etc/rc.conf.local file. Variables set in this file will override variables previously set in /etc/rc.conf.
There are four sections in this file. The first is used to turn
features on or off. For example, whether the system runs the
dhcpd daemon is determined by the line in this
dhcpd_flags=NO # for normal use: ""
If this line is edited to contain some valid dhcpd daemon command-line flags, such as
dhcpd_flags="-A abandoned" # for normal use: ""
then the dhcpd daemon will be started with those options.
The second section contains some other programs that can either be run or not, but that don't need options. They can be set to YES or NO. For example, the line
prevents the NFS server daemons from starting. To run NFS, just change this line's value from NO to YES, and also make whatever changes are needed for the server to have something to do (set up the exports(5) file etc.).
The third section contains values that parameterize servers
started by one of the first two sections, and are ignored if the
corresponding server is not running. For example, if
nfs_server, is enabled, then the line
provides command-line arguments for the NFS server.
This particular line instructs nfsd(8) to start four copies of the server. On a busy file server, 8 (or more) copies are recommended.
The fourth section contains the pkg_scripts variable, responsible for starting and stopping rc.d(8) scripts installed by packages in the specified order. For example, the following line
will run /etc/rc.d/dbus_daemon then /etc/rc.d/cupsd with the start argument at boot time and in reverse order with the stop argument at shutdown.init(8), intro(8), rc(8)
rc.conffile first appeared in OpenBSD 2.2.
|July 8, 2011||OpenBSD-5.1|