|SCSI(4)||Device Drivers Manual||SCSI(4)|
— SCSI system
cd* at scsibus?
ch* at scsibus?
safte* at scsibus?
sd* at scsibus?
ses* at scsibus?
st* at scsibus?
uk* at scsibus?
# multipath support
emc* at scsibus?
hds* at scsibus?
rdac* at scsibus?
sym* at scsibus?
The SCSI system provides a uniform and modular system for the implementation of drivers to control various SCSI devices, and to utilize different SCSI host adapters through host adapter drivers. When the system probes the SCSI buses, it attaches any devices it finds to the appropriate drivers. If no driver seems appropriate, then it attaches the device to the uk (unknown) driver so that user level SCSI ioctls may still be performed against the device.
The option SCSIDEBUG enables the debug ioctl.
All devices and the SCSI buses support boot time allocation so
that an upper number of devices and controllers does not need to be
sd* at scsibus? will suffice for any
number of disk drivers.
To configure a driver in the kernel without wiring down the device
use a config line similar to
ch* at scsibus? to
include the changer driver.
To wire down a unit use a config line similar to
ch1 at scsibus0 target 4 lun 0 to assign changer 1
as the changer with SCSI ID 4, SCSI logical unit 0 on SCSI bus 0. Individual
scsibuses can be wired down to specific controllers with a config line
scsibus0 at ahc0 which assigns SCSI bus 0
to the first unit using the ahc driver. For controllers supporting more than
one bus, the particular bus can be specified as in
at ahc1 bus 1 which assigns scsibus 1 to the second bus probed on the
When there is a mixture of wired down and counted devices
then the counting begins with the first non-wired down unit for a particular
type. That is, if a disk is wired down as
scsibus?, then the first non-wired disk shall come on line as
There are a number of ioctls that work on any
SCSI device. They are defined in
<sys/scsiio.h> and can be
applied against any SCSI device that permits them. For the tape, it must be
applied against the control device. See the manual page for each device type
for more information about how generic SCSI ioctls may be applied to a
SCIOCIDENTIFYstruct scsi_addr *
The system allows common device drivers to work through many different types of adapters. The adapters take requests from the upper layers and do all I/O between the SCSI bus and the system. The maximum size of a transfer is governed by the adapter. Most adapters can transfer 64KB in a single operation, and many can transfer larger amounts.
When the kernel is compiled with option SCSIDEBUG, the SCIOCDEBUG ioctl can be used to enable various amounts of tracing information on any specific device. Devices not being traced will not produce trace information. The four bits that make up the debug level each control certain types of debugging information.
scsi system appeared in MACH 2.5 at
|November 21, 2015||OpenBSD-6.0|