|SD(4)||Device Drivers Manual||SD(4)|
sd — SCSI disk
sd* at scsibus?
#sd0 at scsibus0 target 3 lun 0 (fixed-configuration
SCSI devices have a fairly high level interface to the system and talk to it via a SCSI host adapter (e.g., ahc(4)). A SCSI adapter must also be separately configured into the system before a SCSI disk can be configured.
When the SCSI adapter is probed during boot, the SCSI
bus is scanned for devices. Any devices found which answer as
type devices will be attached to the
On many systems disklabel(8) is used to partition the drive into filesystems. On some systems the OpenBSD portion of the disk resides within a native partition, and another program is used to create the OpenBSD portion.
For example, the i386 port uses fdisk(8) to partition the disk into a BIOS level partition. This allows sharing the disk with other operating systems.
DIOCGDINFOstruct disklabel *
DIOCSDINFOstruct disklabel *
DIOCWDINFOstruct disklabel *
DIOCINQstruct dk_inquiry *
If a removable device is attached to the
sd driver, then the act of changing the media will
invalidate the disklabel and information held within the kernel. To avoid
corruption, all access to the device will be discarded until there are no
more open file descriptors referencing the device. During this period, all
new open attempts will be rejected. When no more open file descriptors
reference the device, the first next open will load a new set of parameters
(including disklabel) for the drive.
sd driver was originally written for
Mach 2.5, and was ported to FreeBSD by Julian
Elischer. It was later ported to OpenBSD.
|July 2, 2014||OpenBSD-6.0|