|INTRO(8)||System Manager's Manual||INTRO(8)|
There are pages which document the running of the system, such as afterboot(8), ifconfig(8), security(8), and the configuration files located in /etc. Procedures concerning system failure are documented in crash(8).
Section 8 pages also describe network services and daemons. The rest of this page discusses some of the main daemons available on the OpenBSD system, and how to enable/disable them.
Thus it is not started by default. To enable or disable daemon processes, administrators should edit the file rc.conf.local(8) or use the rcctl(8) utility. The rc.conf.local(8) file overrides variable assignments in rc.conf(8). So to enable httpd(8), the following line might be added to /etc/rc.conf.local:
As can be seen above, this method is also used to specify additional options.
Below is a list of some of the daemons available. For further information, see rc(8) and the individual pages for the utilities.amd(8) daemon, go into the /etc/amd directory and set it up by renaming master.sample to master and editing it and creating other maps as needed. Alternatively, you can get your maps with YP.
Relevant rc.conf(8) variables: amd_flags and amd_master./etc/resolv.conf file. It may look something like:
domain nts.umn.edu nameserver 18.104.22.168 nameserver 22.214.171.124 search nts.umn.edu. umn.edu. lookup file bind
If using a caching name server, add the line "nameserver 127.0.0.1" first.
Relevant rc.conf(8) variables: nsd_flags and unbound_flags.ntpd(8) and rdate(8).
Relevant rc.conf(8) variables: ntpd_flags./etc/dhcpd.conf as needed. See also diskless(8).
Relevant rc.conf(8) variables: bootparamd_flags, dhcpd_flags, and dhcrelay_flags./etc/rbootd.conf if needed for remote booting. If you do not have HP computers doing remote booting, do not enable this. See also diskless(8).
Relevant rc.conf(8) variables: rbootd_flags.OpenBSD it will chroot(2) to /var/www. Detailed information is available in httpd(8) and httpd.conf(5).
Relevant rc.conf(8) variables: httpd_flags./etc/exports.
Relevant rc.conf(8) variables: mountd_flags and nfsd_flags.relayd(8), able to run as a load-balancer, application layer gateway, or transparent proxy.
Relevant rc.conf(8) variables: relayd_flags.bgpd(8), eigrpd(8), ospfd(8), and ripd(8).
Relevant rc.conf(8) variables: bgpd_flags, eigrpd_flags, ospfd_flags, and ripd_flags.portmap(8), being running for proper operation. This includes YP and NFS exports, among other services.
Relevant rc.conf(8) variables: portmap_flags.domainname(1) command. If necessary, correct it by editing the /etc/defaultdomain file (see defaultdomain(5)). The /etc/netstart script reads this file on boot to determine and set the domain name. You may also set the running system's domain name with the domainname(1) command.
Relevant rc.conf(8) variables: ypbind_flags.
In particular, to enable YP passwd support, you'll need to add the following line to /etc/master.passwd:
You do this by using vipw(8).
There are many more YP man pages available to help you. You can find more information by starting with yp(8).afterboot(8), rc(8), rc.conf(8), rcctl(8)
introsection manual page appeared in 4.2BSD.
|November 4, 2015||OpenBSD-6.1|