|RDATE(8)||System Manager's Manual||RDATE(8)|
rdate — set the
system's date from a remote host
rdate displays and sets the local date and
time from the host name or address given as the argument. The time source
may be an RFC 5905 protocol SNTP/NTP server or an RFC 868 TCP protocol
server, which is usually implemented as a built-in service of
inetd(8). By default,
rdate uses the RFC 5905 SNTP/NTP protocol.
The options are as follows:
rdateto use IPv4 addresses only.
rdateto use IPv6 addresses only.
To get the legal time in Germany, set the /etc/localtime symlink to /usr/share/zoneinfo/right/Europe/Berlin and issue the following command:
# rdate -v ptbtime1.ptb.de
The command of course assumes you have a working internet connection and DNS set up to connect to the server at Physikalisch-Technische Bundesanstalt in Braunschweig, Germany.
|February 10, 2015||OpenBSD-6.1|