|vmm(4/amd64)||virtual machine monitor|
|vmm(4/i386)||virtual machine monitor|
|VMM(4)||Device Drivers Manual (amd64)||VMM(4)|
vmm0 at mainbus0
vmmdriver implements a virtual machine monitor (VMM) suitable for executing virtual machines (VMs). A VMM runs on the host operating system and provides facilities to execute one or more VMs, each of which is provided with a suitable complement of virtual hardware.
These VMs run independently of the host, but may interact with it as any other machine would (e.g. via network communications or other means).
VMs are allocated hardware resources by the VMM during creation, including:
Although VMs execute independently of each other and the host, they do consume host resources and, as such, the number of VMs (and their configurations) should be taken into consideration when planning host capacity.
vmm driver requires suitable host CPU
capabilities in order to provide VM services. The
vmm driver requires at least one CPU with
hardware-assisted virtualization capabilities and nested or extended paging
capabilities to be present on the host. For more information, consult the
CPU vendor's documentation.
vmmdriver appeared in OpenBSD 5.9. Mike Larkin <firstname.lastname@example.org>
|December 6, 2015||OpenBSD-current|