|VIRTIO(4)||Device Drivers Manual||VIRTIO(4)|
virtio* at fdt?
virtio* at pci? flags 0x00
virtiodriver provides support service for paravirtualized devices using the VirtIO protocol. Such devices are provided by bhyve, KVM, QEMU, VirtualBox, and vmm(4).
Currently there are drivers for the following
virtio driver conforms to the virtio
0.9.5 specification. The virtio 1.0 standard is only supported for PCI
By default 0.9 is preferred over 1.0. This can be changed by setting the bit 0x4 in the flags. Setting the bit 0x8 in the flags disables 1.0 support completely.
virtiodriver first appeared in OpenBSD 5.3.
virtiodriver was ported to OpenBSD and improved by Stefan Fritsch <firstname.lastname@example.org>. It is based on the NetBSD driver by Minoura Makoto.
virtiobig-endian architectures are not yet supported.
|May 26, 2019||OpenBSD-current|