|VIO(4)||Device Drivers Manual||VIO(4)|
vio* at virtio? flags 0x00
viodriver provides support for the virtio(4) network interface provided by bhyve, KVM, QEMU, and VirtualBox.
Setting the bit 0x2 in the flags disables the RingEventIndex
feature. This can be tried as a workaround for possible bugs in host
vio at the cost of slightly
Setting the bit 0x100 in the flags forces the interface to be always in promiscuous mode. This can be used as a workaround for a bug in QEMU before version 1.7.2 that prevents packets with a VLAN tag from being sent to the guest.intro(4), virtio(4)
viodriver first appeared in OpenBSD 5.3.
viodriver was ported to OpenBSD and improved by Stefan Fritsch <email@example.com>. It is based on the NetBSD
vioifdriver by Minoura Makoto.
|September 24, 2015||OpenBSD-current|