OpenBSD manual page server

Manual Page Search Parameters

VGONE(9) Kernel Developer's Manual VGONE(9)

vgone, vgonelprepare a vnode for reuse

#include <sys/param.h>
#include <sys/vnode.h>

void
vgone(struct vnode *vp);

void
vgonel(struct vnode *vp, struct proc *p);

() and () prepare the vnode vp for reuse by another file system. The preparation includes the cleaning of all file system specific data and the removal from its mount point vnode list. The p argument specifies the process responsible for the call.

() is identical to () with a p value of curproc.

vclean(9), vnode(9), vrecycle(9)

This man page was originally written by Chad David <davidc@acns.ab.ca> for FreeBSD.

August 5, 2020 OpenBSD-current