|VRECYCLE(9)||Kernel Developer's Manual||VRECYCLE(9)|
vrecycle — recycle
a vnode if its reference count is zero
vrecycle(struct vnode *vp,
struct proc *p);
vrecycle() function places the vnode
vp on the free list using
vgonel(9) if its
v_usecount field is zero. If
v_usecount is non-zero, it simply returns.
vrecycle() will return 1 if the vnode was
placed on the free list. It will return 0 if the reference count was
This man page was originally written for OpenBSD.
|June 4, 2013||OpenBSD-current|