|UNWIND(8)||System Manager's Manual||UNWIND(8)|
unwindis a validating DNS resolver. It is intended to run on client machines like workstations or laptops and only listens on localhost.
unwindsends DNS queries to nameservers to answer queries and switches to resolvers learned from dhclient(8) if it detects that DNS queries are blocked by the local network. It periodically probes if DNS is no longer blocked and switches back to querying nameservers itself.
unwind is usually started at boot time,
and can be enabled by setting the following in
prepend domain-name-servers 127.0.0.1;
unwind can be controlled with
the unwindctl(8) utility.
The options are as follows:
unwindwill run in the foreground and log to stderr.
-voptions increase the verbosity.
P. Mockapetris, DOMAIN NAMES - IMPLEMENTATION AND SPECIFICATION, RFC 1035, November 1987.
unwindprogram first appeared in OpenBSD 6.5.
unwindprogram was written by Florian Obser <firstname.lastname@example.org>.
|February 11, 2019||OpenBSD-current|