|RESOLVD(8)||System Manager's Manual||RESOLVD(8)|
resolvd — a daemon
to handle nameserver configuration
resolvd handles the contents of
/etc/resolv.conf, which contains details of the
system's DNS nameservers, and is read by the resolver routines in the C
library. Nameservers are learned from various sources, incorporated in a
priority order, then user-edited information found in the pre-existing file
resolvd checks whether
unwind(8) is running, and if so
at the top, to cause local resolution.
These proposals are added in priority order, but commented out if unwind(8) is running.
resolvd appends all
user-edited lines found in the file.
resolvd also notices if the
/etc/resolv.conf file is edited, and will rewrite
the file, re-blending the various pieces of information. It will also create
/etc/resolv.conf if it does not exist or if it is
The options are as follows:
resolvd program first appeared in
|May 2, 2021||OpenBSD-current|