|SPAMDB(8)||System Manager's Manual||SPAMDB(8)|
spamdb — spamd
spamdb manipulates the spamd database in
/var/db/spamd used for
The options are as follows:
spamdbupdates the entry's time last seen to now.
If adding or deleting a SPAMTRAP address
-T), keys should be specified
as email addresses:
Otherwise keys must be numerical IP addresses.
If invoked without any options,
lists the contents of the database in a text format. If one or more
keys are specified, only matching entries will be
For SPAMTRAP entries the format is:
where type will be SPAMTRAP and mailaddress will be the email address for which any connections received by spamd(8) will be blacklisted if mail is sent to this address.
For TRAPPED entries the format is:
where type will be TRAPPED, IP will be the IP address blacklisted due to hitting a spamtrap, and expire will be when the IP is due to be removed from the blacklist.
For GREY entries, the format is:
For WHITE entries, the format is:
The fields are as follows:
Note that times are in seconds since the Epoch, in the manner returned by time(3). Times may be converted to human readable format using:
$ date -r <value>
spamdb command appeared in
|October 29, 2017||OpenBSD-current|