|SPAMD-SETUP(8)||System Manager's Manual||SPAMD-SETUP(8)|
spamd-setuputility sends blacklist data to spamd(8), as well as configuring mail rejection messages for blacklist entries.
spamd-setup is run in blacklist only
mode, it also sends blacklist data to the
<spamd>. The <spamd>
table must then be used in conjunction with a
pf(4) redirection rule to selectively
redirect mail connections to spamd(8).
The options are as follows:
spamd-setupin the background.
Lists are specified in the configuration file /etc/mail/spamd.conf and are processed in the order specified in the all tag. Output is concatenated and sent to a running spamd(8). Addresses are sent along with the message spamd will give on mail rejection when a matching client connects. The configuration port for spamd(8) is found from services(5), by looking for the named service spamd-cfg.
/etc/mail/spamd.conf are not
automatically removed from the running
spamd(8). If an entry is removed from
/etc/mail/spamd.conf that is currently in use, it is
necessary to restart spamd(8). This applies
only to blacklists that are removed entirely, not those that are simply
spamd-setup reads all configuration
information from the spamd.conf(5)
|March 31, 2016||OpenBSD-current|