|SPAMLOGD(8)||System Manager's Manual||SPAMLOGD(8)|
spamlogdmanipulates the spamd(8) database in /var/db/spamd used for greylisting.
spamlogdupdates the /var/db/spamd whitelist entries whenever a connection to port 25 is logged to the pflog(4) interface. The source addresses of inbound connections are whitelisted when seen by
spamlogdto ensure that their entries in /var/db/spamd do not expire if the connecting host continues to send legitimate mail. The destination addresses of outbound connections are whitelisted when seen by
spamlogdso that replies to outbound mail may be received without initial greylisting delays. Greylisting is explained more fully in spamd(8). The options are as follows:
spamlogddoes not disassociate from the controlling terminal.
spamlogdis only to whitelist inbound SMTP connections. By default
spamlogdwill whitelist the source of inbound SMTP connections, and the target of outbound SMTP connections.
spamlogdto update the whitelist entries. See spamd(8) for an example ruleset for logging such connections.
spamlogdsends log messages to syslogd(8) using facility daemon.
spamlogdwill log each connection it sees at level
spamlogdsupports realtime synchronisation of whitelist states by sending the information it updates to a number of spamd(8) daemons running on multiple machines. To enable synchronisation, use the command line option
-Yto specify the machines to which
spamlogdwill send messages when it updates the state information. For more information, see spamd(8). /var/db/spamd syslog(3), pflog(4), spamd.conf(5), pflogd(8), spamd(8), spamd-setup(8), spamdb(8), syslogd(8), tcpdump(8)
spamlogdcommand first appeared in OpenBSD 3.5.
|September 15, 2013||OpenBSD-current|