|route(8)||manually manipulate the routing tables|
|route(4)||kernel packet forwarding database|
|route, rt_setgate, rtdeletemsg, rtredirect(9)||kernel routing interface|
|ROUTE(8)||System Manager's Manual||ROUTE(8)|
route — manually
manipulate the routing tables
route is a utility used to manually view
and manipulate the network routing tables.
be used to modify nearly any aspect of the routing policy, except packet
forwarding, which can be manipulated through the
route utility supports a limited
number of general options, but a rich command language enables the user to
specify any arbitrary request that could be delivered via the programmatic
interface discussed in route(4).
The options are as follows:
route utility provides
the following simple commands:
-gatewayis specified, only routes whose gateway are in the same address family as the destination are shown.
When the address family is specified by any one of the
family modifiers (listed below), only routes
having destinations with addresses in the delineated family will be
shown. If the
-iface modifier is used only
interface specific messages (link state changes) are shown. If a routing
table is supplied with
-T, only changes in that
routing table will be displayed.
-gateway is specified, only routes
whose gateway are in the same address family as the destination are
-label is specified, only routes
with the specified label are shown.
-priority is specified, only routes
with the specified priority are shown. It may be specified by number or
bgp. If the
priority is negative, then routes that do not match the numeric priority
Set the preferred source address. If
address is the word "default", 0.0.0.0
or ::, source address will be chosen by the kernel for the matching
address family. When address is omitted, preferred
source address is printed if set. If
used, source will use IP assigned to interface.
The preferred source will not be used when:
The other commands relating to adding, changing, or deleting routes have the syntax:
add[modifiers] destination gateway
change[modifiers] destination gateway
ete] [modifiers] destination gateway
destination is the destination host
or network; gateway is the next-hop intermediary via
which packets should be routed. Routes to a particular host may be
distinguished from those to a network by interpreting the Internet address
specified as the destination argument. The optional
cause the destination to be interpreted as a network or a host,
respectively. Otherwise, type is chosen based on the following rules:
The route is assumed to be to a network if any of the following apply to destination:
If destination is a valid IP address or host name, it is presumed to be a route to a host.
192.168.1.1 is interpreted as
192.168.1 is interpreted as
192.168.2.0 will be interpreted as
192.168.2.0 since it
is a complete IP address with 3 dots. In this case the number of bits in the
network portion of the address must be explicitly listed, for example
192.168.2/24, or alternately
If the destination is directly reachable via an
interface requiring no intermediary system to act as a gateway, the
modifier should be specified; the gateway given is the address of this host
on the common network, indicating the interface to be used for
To allow addresses to be interpreted as belonging to a particular address family (as well as for use in the family arguments to some commands), the following modifiers may be used:
In the absence of modifiers, an address is assumed to be IPv4, unless containing a ‘:’ character, when it is treated as IPv6.
The optional modifier
-link specifies that
all subsequent addresses are specified as link-level addresses, and the
names must be numeric specifications rather than symbolic names.
qualifier is intended to manually add subnet routes with netmasks different
from that of the implied network interface (as would otherwise be
communicated using a routing protocol). One specifies an additional ensuing
address parameter (to be interpreted as a network mask). The implicit
network mask generated in the
AF_INET case can be
overridden by making sure this option follows the
is also available for a similar purpose, for IPv6/v4.
A specific routing priority can be specified with
qualifier. If no priority is specified the kernel will set a priority
depending on the
RTF_STATIC flag to either
Note that priority 1 is reserved for kernel use.
modifier needs to be specified with the
to be able to enter multiple gateways for the same destination address
(multipath). When multiple routes exist for a destination, one route is
selected based on the source address of the packet. The
net.inet6.ip6.multipath are used to control multipath
routing. If set to 1, multiple routes with the same priority are used
equally; if set to 0, the first route selected will be used for subsequent
packets to that destination regardless of source.
When inserting MPLS routes, particular modifiers
must be used. The
modifier needs to be specified in an ingress LSR to associate a particular
label to an IPv4/IPv6 route. The MPLS traffic
-out modifiers are intended to identify the
ingress label and, optionally, the outgoing one. Additionally, one of the
following operations must be used:
nexthop can be specified with the modifier
Routes have associated flags which influence operation of the protocols when sending to destinations matched by the routes. These flags may be set (or sometimes cleared) by indicating the following corresponding modifiers:
||silently discard pkts (during updates)|
||generates a new route on use|
||destination is directly reachable|
||validly translates proto addr to link addr|
||multiple gateways for a destination exist|
||pretend route added by kernel or daemon|
||set protocol specific routing flag #1|
||set protocol specific routing flag #2|
||emit an ICMP unreachable when matched|
||manually added route|
The optional modifiers
-mtu provide initial values to quantities maintained
in the routing entry by transport level protocols, such as TCP (see
tcp(4)). They have the following
These may be individually locked by preceding each such
modifier to be locked by the
meta-modifier, or one can specify that all ensuing metrics may be locked by
modifier specifies on route addition or modification that the route should
have the given label associated with it. Route labels can
be used to attach arbitrary information to a route.
All symbolic names specified for a destination or gateway are looked up using gethostbyname(3).
route uses a routing socket (see
route(4)) and the message types
such, only the superuser may modify the routing tables.
Add a static inet(4) route to the 192.168.5.0/24 network via the 192.168.0.1 gateway:
# route add -inet 192.168.5.0/24 192.168.0.1
Amend the inet(4) route to the 192.168.5.0/24 network to use the 192.168.0.2 gateway:
# route change -inet 192.168.5.0/24 192.168.0.2
Delete the inet(4) route to the 192.168.5.0/24 network:
# route delete -inet 192.168.5.0/24
flushcommand is specified, each routing table entry deleted is indicated with a message of this form.
deleteoperation was attempted for an entry which wasn't present in the tables.
addoperation was attempted, but the system was low on resources and was unable to allocate memory to create the new entry.
route command appeared in
4.2BSD. IPv6 support was added by WIDE/KAME
-rttvar modifiers used to be used to initialize
various quantities in routing table entries. The routing system no longer
uses these values and the modifiers exist now only for compatibility with
other operating systems.
Some uses of the
-ifp modifiers with the
command will incorrectly fail with a “Network is unreachable”
message if there is no default route. See case
from sys/net/rtsock.c for details.
|January 2, 2021||OpenBSD-current|