|NEWFS_EXT2FS(8)||System Manager's Manual||NEWFS_EXT2FS(8)|
construct a new ext2 file system
newfs_ext2fs is used to initialize and
clear ext2 file systems before first use. Before running
newfs_ext2fs the disk must be labeled using
newfs_ext2fs builds a file system on the specified
special device, basing its defaults on the information
in the disk label. Typically the defaults are reasonable, although
newfs_ext2fs has numerous options to allow the
defaults to be selectively overridden.
The special file should be a raw device, for example /dev/rsd0a; if a relative path like sd0a is specified, the corresponding raw device is used.
Options with numeric arguments may contain an optional (case-insensitive) suffix:
The following options define the general layout policies.
-ssize”. No attempts to use or update the disk label will be made.
-nare specified then
-ntakes precedence. The default number of inodes is calculated from a number of blocks in the file system.
GOOD_OLD_REV’; this option is primarily used to build root file systems that can be understood by old or dumb firmware for bootstrap. (default)
DYNAMIC_REV’; various extended (and sometimes incompatible) features are enabled (though not all features are supported on OpenBSD). Currently only the following features are supported:
-Ssecsize) after suffix interpretation.
-s size is
specified then the filesystem size defaults to that of the partition or,
-F is specified, the existing file.
If size is negative the specified size is subtracted from the default size (reserving space at the end of the partition).
The default is 4. If
-N is specified
newfs_ext2fs stops before outputting the
-F. This is necessary if the image is to be used by vnd(4) (which doesn't support file systems with ‘holes’).
The following option overrides the standard sizes for the disk
geometry. The default value is taken from the disk label. Changing this
default is useful only when using
build a file system whose raw image will eventually be used on a different
type of disk than the one on which it is initially created (for example on a
write-once disk). Note that changing this value from its default will make
it impossible for fsck_ext2fs(8) to
find the alternative superblocks if the standard superblock is lost.
There is no option to specify the metadata byte order on the file system to be created because the native ext2 file system is always little endian even on big endian hosts.
The file system is created with ‘random’ inode generation numbers to improve NFS security.
The owner and group IDs of the root node and reserved blocks of the new file system are set to the effective UID and GID of the user initializing the file system.
newfs_ext2fs command to succeed,
the disk label should first be updated such that the fstype field for the
partition is set to ‘
-I is used.
The partition size is found using fstat(2), not by inspecting the disk label. The block size and fragment size will be written back to the disk label only if the last character of special references the same partition as the minor device number.
Remy Card, Theodore Ts'o, and Stephen Tweedie, Design and Implementation of the Second Extended Filesystem, The Proceedings of the First Dutch International Symposium on Linux, http://e2fsprogs.sourceforge.net/ext2intro.html.
newfs_ext2fs command first appeared in
newfs_ext2fs command was written by
newfs_ext2fs command is still
experimental and there are few sanity checks.
newfs_ext2fs command doesn't have
options to specify each REV1 file system feature independently.
newfs_ext2fs command doesn't support
the bad block list accounted by the bad blocks inode.
Many newer ext2 file system features (especially journaling) are not supported yet.
Some features in file systems created by the
newfs_ext2fs command might not be recognized
properly by the fsck_ext2fs(8)
There is no native tool in the OpenBSD distribution for resizing ext2 file systems yet.
|March 13, 2015||OpenBSD-current|