|NETID(5)||File Formats Manual||NETID(5)|
netid — YP network
The file /etc/netid consists of newline separated ASCII records. Each record consists of a key, a single blank character, and a value. The key and the value may be arbitrary strings except that neither may contain blank characters.
Records in the file /etc/netid and in the netid.byname YP map are ignored by the system unless they have the following form:
When YP is enabled in the group(5) file, such records specify that the function getgrouplist(3) shall return the specified groups in addition to the groups found in the group file. The file /etc/netid is parsed before the netid.byname YP map. Only the first matching record is used.
The main use of the /etc/netid file is to allow certain users to log in even while YP is enabled but temporarily unavailable. These users must also be listed in the local master.passwd(5) file. If consistency of group membership information is required while YP is enabled and available, all records in the /etc/netid file must agree with records in the netid.byname YP map, although the latter may contain additional records. If consistency of group membership information is required even while YP is enabled but unavailable, the records in the /etc/netid file must not grant more group memberships than the group(5) file, and users having their own record in the /etc/netid file must not show up in the group.byname and group.bygid YP maps.
Such records are ignored by the system.
A netid file or YP map might look like the following:
unix.10714@kaka 10714:400,10 unix.jodie@kaka 0:jodie
Mats O Jansson <firstname.lastname@example.org>
|July 16, 2013||OpenBSD-current|