|DMA_ALLOC(9)||Kernel Developer's Manual||DMA_ALLOC(9)|
dma_free — DMA-safe memory
This allocator provides DMA-safe memory managed using the pool(9) interface. It is safe to call in most contexts and is typically used for temporary buffers up to 65536 bytes. When buffers are used many times it may be better to consider using other DMA-safe allocators.
Interrupt protection is set to IPL_VM using pool_init(9).
The flags argument is a selection of pool_get(9) flag arguments.
dma_alloc interface first appeared in
|September 15, 2016||OpenBSD-current|