|POOL_INIT(9)||Kernel Developer's Manual||POOL_INIT(9)|
pool_init(struct pool *pool,
size_t size, u_int align,
int ipl, int flags,
const char *wmesg, struct
pool *pp, int
pool *pp, void
pool *pp, int
pool *pp, int
pool *pp, int
*pp, unsigned n, const char
*warnmess, int ratecap);
These utility routines provide management of pools of fixed-sized
areas of memory. Resource pools set aside an amount of memory for exclusive
use by the resource pool owner. This can be used by applications to
guarantee the availability of a minimum amount of memory needed to continue
operation independent of the memory resources currently available from the
system-wide memory allocator (malloc(9)).
The pool manager obtains memory by using the special-purpose memory
allocator palloc passed to
pool_init(), for extra pool items in case the number
of allocations exceeds the nominal number of pool items managed by a pool
resource. This temporary memory will be automatically returned to the system
at a later time.
pool_init() initializes a
resource pool. The arguments are:
pool_get(). This argument must be a power of two. If zero, the alignment defaults to an architecture-specific natural alignment.
PR_WAITOKto be specified as well, both to
pool_init() and on all
pool_get() calls on this pool.
pool_get() must wait for items to be returned to the pool.
NULL, in which case the pool manager chooses an appropriate back-end allocator.
pool_destroy() function destroys a
resource pool. It takes a single argument pp
identifying the pool resource instance.
pool_get() allocates an item from the pool
and returns a pointer to it.
PR_NOWAITmust be specified to define behaviour in case the pooled resources are depleted. If no resources are available and
PR_NOWAITwas specified, this function returns
PR_WAITOKwas specified but
pool_get() will wait until items are returned to the pool. If both
PR_LIMITFAILwere specified, and the pool has reached its hard limit,
pool_get() will return
NULLwithout waiting, allowing the caller to do its own garbage collection; however, it will still wait if the pool is not yet at its hard limit. If
PR_ZEROwas specified and an item has been successfully allocated, it is zeroed before being returned to the caller.
pool_put() returns the pool item pointed
at by item to the resource pool identified by the pool
handle pp. If the number of available items in the
pool exceeds the maximum pool size set by
pool_sethiwat() and there are no outstanding
requests for pool items, the excess items will be returned to the system if
If a non-interrupt safe allocator has been selected by passing the
PR_WAITOK flag to
sleep when completely unused pages are released.
pool_prime() adds items to the pool.
Storage space for the items is allocated by using the page allocation
routine specified to
A pool will attempt to increase its resource usage to keep up with
the demand for its items. Conversely, it will return unused memory to the
system should the number of accumulated unused items in the pool exceed a
programmable limit. The limits for the minimum and maximum number of items
which a pool should keep at hand are known as the high and low
watermarks. The functions
pool_setlowat() set a pool's high and low
pool_prime(), this function does not allocate the necessary memory up-front.
pool_sethardlimit() sets a
hard limit on the pool to n items. If the hard limit
is reached warnmess will be printed to the console,
but no more than every ratecap seconds. Upon
successful completion, a value of 0 is returned. The value EINVAL is
returned when the current size of the pool already exceeds the requested
Note that undefined behaviour results when mixing the storage providing methods supported by the pool resource routines.
The pool resource code uses a per-pool lock to protect its internal state. If any pool functions are called in an interrupt context, the caller must block all interrupts that might cause the code to be reentered.
pool_sethardlimit() can be called during autoconf or
from process context.
pool_put() can be called during autoconf or from
process context. If the pool has been initialised with an interrupt safe
pool allocator they can also be called from interrupt context at or below
the interrupt level specified by a call to
pool_get() will return a pointer to an
item allocated from the pool. If
PR_LIMITFAIL were passed as flags to the pool it may
NULL if there are no resources available or
if the pool hard limit has been reached, respectively.
pool_prime() will return
ENOMEM if the requested number of items could not be
allocated. Otherwise, the return value is 0.
pool_sethardlimit() will return
EINVAL if the current size of the pool exceeds the
requested hard limit. Otherwise, the return value is 0.
The pool manager is implemented in the file sys/kern/subr_pool.c.
The pool manager first appeared in NetBSD 1.4 and was ported to OpenBSD by Artur Grabowski <firstname.lastname@example.org>.
|August 14, 2017||OpenBSD-current|