|DHCPLEASED(8)||System Manager's Manual||DHCPLEASED(8)|
dhcpleased — a
dynamic host configuration protocol daemon
dhcpleased is a dynamic host configuration
protocol (DHCP) daemon for clients. It requests IP configuration information
from for example those offered by
dhcpd(8), on interfaces with the
flag set. See hostname.if(5) and
ifconfig(8) on how to enable auto
configuration on an interface.
dhcpleased monitors network interface
states (interface going up or down, auto configuration enabled or disabled
etc.) and sends requests when necessary.
dhcpleased can be controlled
with the dhcpleasectl(8)
The options are as follows:
dhcpleasedwill run in the foreground and log to stderr.
-voptions increase the verbosity.
R. Droms, Dynamic Host Configuration Protocol, RFC 2131, March 1997.
S. Alexander and R. Droms, DHCP Options and BOOTP Vendor Extensions, RFC 2132, March 1997.
dhcpleased program first appeared in
dhcpleased program was written by
|July 26, 2021||OpenBSD-current|