|DHCPLEASED.CONF(5)||File Formats Manual||DHCPLEASED.CONF(5)|
dynamic host configuration protocol client daemon
The dhcpleased(8) daemon is a dynamic host configuration protocol client daemon.
dhcpleased.conf config file is divided
into the following main sections:
Macros can be defined that will later be expanded in context.
Macro names must start with a letter, digit, or underscore, and may contain
any of those characters. Macro names may not be reserved words (for example,
interface). Macros are not expanded inside
A list of interfaces to overwrite defaults:
interface options are as follows:
send client idclient-id
send client id "01:00:53:FF:AA:BB:CC"
Otherwise the string client-id is sent verbatim. The default is to send the interface's MAC address as client identifier.
When client-id is not a hardware
address, it is supposed to be sent as hardware type 0 but the majority
of DHCP clients and servers do not implement this and neither does
dhcpleased.conf. If a server is encountered that
requires this, a 0 byte can be encoded as \0. The client identifier
“foobar” with hardware type 0 would be configured as:
send client id "\0foobar"
send host namehost-name
send no host name
send vendor class idvendor-class-id
|June 14, 2022||OpenBSD-current|