|BOOTPARAMS(5)||File Formats Manual||BOOTPARAMS(5)|
bootparams — boot
bootparams file specifies the boot
parameters that diskless(8) clients may
request when booting over the network. Each client supported by this server
must have an entry in the
bootparams file containing
the pathnames for its "root" and (optionally) "swap"
Each line in the file (other than comment lines that begin with a ‘#’) specifies the client name followed by the pathnames that the client may request by their logical names. The components of the line are delimited with blank or tab, and may be continued onto multiple lines with a backslash.
client root=server:/export/client/root \ swap=server:/export/client/swap \ dump=server:/export/client/swap
When the client named "client" requests the pathname for its logical "root" it will be given the server name "server" and the pathname /export/client/root as the response to its RPC request.
A line containing simply ‘+’ will cause YP lookups to be done on the YP map "bootparams".
|July 13, 2017||OpenBSD-current|