|MAKEMAP(8)||System Manager's Manual||MAKEMAP(8)|
makemap — create
database maps for smtpd
Maps provide a generic interface for associating a textual key to
a value. Such associations may be accessed through a plaintext file,
database, or DNS. The format of these file types is described below.
makemap itself creates the database maps used by
keyed map lookups specified in
makemap reads input from
file and writes data to a file which is named by
adding a “.db” suffix to file. The
current line can be extended over multiple lines using a backslash
(‘\’). Comments can be put anywhere in the file using a hash
mark (‘#’), and extend to the end of the current line. Care
should be taken when commenting out multi-line text: the comment is
effective until the end of the entire block. In all cases,
makemap reads lines consisting of words separated by
whitespace. The first word of a line is the database key; the remainder
represents the mapped value. The database key and value may optionally be
separated by the colon character.
The options are as follows:
Primary domains can be kept in tables. To create a primary domain table, add each primary domain on a single line by itself.
In addition to adding an entry to the primary domain map, one must add a filter rule that accepts mail for the domain map, for example:
table domains db:/etc/mail/domains.db action "local" mbox match for domain <domains> action "local"
Virtual domains may also be kept in tables. To create a virtual domain table, add each virtual domain on a single line by itself.
Virtual domains expect a mapping of virtual users to real users in order to determine if a recipient is accepted or not. The mapping format is an extension to aliases(5), which allows the use of “email@example.com” to accept user only on the specified domain, “user” to accept the user for any of the virtual domains, “@domain.tld” to provide a catch-all for the specified domain and “@” to provide a global catch-all for all domains. smtpd(8) will perform the lookups in that specific order.
To create a single virtual address, add “firstname.lastname@example.org user” to the users map. To handle all mail destined to any user at example.com, add “@example.com user” to the virtual map.
In addition to adding an entry to the virtual map, one must add a filter rule that accepts mail for virtual domains, for example:
table vdomains db:/etc/mail/vdomains.db table vusers db:/etc/mail/users.db action "local" mbox virtual <vusers> match for domain <vdomains> action "local" match for domain "example.org" action "local"
makemap utility exits 0 on
success, and >0 if an error occurs.
makemap command first appeared in
OpenBSD 4.6 as a replacement for the equivalent
command shipped with sendmail.
|February 13, 2021||OpenBSD-current|