|ALIASES(5)||File Formats Manual||ALIASES(5)|
aliasesfile, as used by smtpd(8). An alias in its simplest form is used to assign an arbitrary name to an email address, or a group of email addresses. This provides a convenient way to send mail. For example an alias could refer to all users of a group: email to that alias would be sent to all members of the group. Much more complex aliases can be defined however: an alias can refer to other aliases, be used to send mail to a file instead of another person, or to execute various commands.
Within the file, ‘
#’ is a
comment delimiter; anything placed after it is discarded. The file consists
of key/value mappings of the form:
key is always folded to lowercase before alias lookups to ensure that there can be no ambiguity. The key is expanded to the corresponding values, which consist of one or more of the following:
aliasesfile format appeared in 4.0BSD.
|May 24, 2018||OpenBSD-current|