|FSCK_FFS(8)||System Manager's Manual||FSCK_FFS(8)|
fsck_ffs — Fast
File System consistency check and interactive repair
fsck_ffs performs interactive file system
consistency checks and repairs the file system specified. It is normally
invoked from fsck(8).
The kernel takes care that only a restricted class of innocuous file system inconsistencies can happen unless hardware or software failures intervene. These are limited to the following:
These are the only inconsistencies that
fsck_ffs with the
will correct; if it encounters other inconsistencies, it exits with an
abnormal return status and an automatic reboot will then fail. For each
corrected inconsistency, one or more lines will be printed identifying the
file system on which the correction will take place along with the nature of
the correction. After successfully correcting a file system,
fsck_ffs will print the number of files on that file
system, the number of used and free blocks, and the percentage of
If sent a
fsck_ffs will finish the file system checks, then
exit with an abnormal return status that causes an automatic reboot to fail.
This is useful when you want to finish the file system checks during an
automatic reboot, but do not want the machine to come up multiuser after the
If sent an
fsck_ffs will print a line to standard error
indicating the name of the device currently being checked, the current phase
number, and phase-specific progress information.
fsck_ffs audits and interactively repairs
inconsistent conditions for the filesystem. If the file system is
inconsistent, the operator is prompted for concurrence before each
correction is attempted. It should be noted that some of the corrective
actions which are not correctable under the
option will result in some loss of data. The amount and severity of data
lost may be determined from the diagnostic output. The default action for
each consistency correction is to wait for the operator to respond
“yes” or “no”. If the operator does not have
write permission on the file system,
default to a
fsck has more consistency checks than its
predecessors check, dcheck,
fcheck, and icheck combined.
The following flags are interpreted by
fsck_ffstries to find a valid alternate superblock based on the information in the disklabel. If that fails, a number printed by
-Ncombined with the original flags used to create the filesystem) can be used as a value to this argument.
fsck_ffswill not check the file system. This option forces
fsck_ffsto check the file system, regardless of the state of the clean flag.
fsck_ffsexcept for “CONTINUE?”, which is assumed to be affirmative. The filesystem will not be opened for writing. This is the default for file systems to be checked that are concurrently mounted writable.
fsck_ffswill check the filesystem on the special (raw) device listed on the command line and will make minor repairs without human intervention. Any major problems will cause
fsck_ffsto exit with a non-zero exit code, so as to alert any invoking program or script that human intervention is required.
fsck_ffs; this should be used with great caution as this is a free license to continue after essentially unlimited trouble has been encountered.
If neither of the
-n options are specified, the user may force
fsck_ffs to assume an answer of “yes”
to all the remaining questions by replying to a question with a value of
In interactive mode,
fsck_ffs will list
the conversion to be made and ask whether the conversion should be done. If
a negative answer is given, no further operations are done on the file
system. In preen mode, the conversion is listed and done if possible without
user interaction. Conversion in preen mode is best used when all the file
systems are being converted at once. The format of a file system can be
determined from the first line of output from
Inconsistencies checked are as follows:
Orphaned files and directories (allocated but unreferenced) are, with the operator's concurrence, reconnected by placing them in the lost+found directory. The name assigned is the inode number. If the lost+found directory does not exist, it is created. If there is insufficient space its size is increased.
Because of inconsistencies between the block device and the buffer cache, the raw device should always be used.
The diagnostics produced by
fully enumerated and explained in Appendix A of
Fsck_ffs - The UNIX File System Check
|September 1, 2016||OpenBSD-current|