|WSCONS(4)||Device Drivers Manual||WSCONS(4)|
wscons — console
wsdisplay* at ...
wskbd* at ... mux N
wsmouse* at ... mux N
pseudo-device wsmux [count]
wscons driver provides support for
machine-independent access to the console.
wscons is made of a number of cooperating
modules, in particular
wscons does not define its own set of
terminal control sequences and special keyboard codes in terms of
termcap(5). Instead, a
“terminal emulation” is assigned to each virtual screen when
the screen is created (see
terminal emulations can be active at the same time on one display.
The following choices are available:
option WSEMUL_SUNwas specified at kernel build time. It supports the control sequences of SUN machine consoles and delivers its keyboard codes for function and keypad keys (as far as present on the actually used keyboard).
ANSI colors are also supported on this emulation, if the
TERM environment variable is set to
This emulation is sufficient for full-screen applications.
option WSEMUL_NO_VT100. It provides the most commonly used functions of DEC VT100 terminals with some extensions introduced by the DEC VT220 and DEC VT320 models. The features of the original VT100 which are not, or not completely, implemented are:
Depending on the keyboard used, not all function keys might be available.
In addition to the plain VT100 functions, the following features are supported:
In most applications,
wscons will work
sufficiently as a VT220 emulator.
The WSEMUL_DEFAULT kernel option allows selecting one of the described terminal options as the default choice. The default goes into effect at kernel startup, i.e., for the operating system console or additional screens allocated through the WSDISPLAY_DEFAULTSCREENS option (see wsdisplay(4)), or if no emulation type was passed to the wsconscfg(8) utility.
Compatibility options: these options allow running X servers or other programs using low-level console driver functions which were written specifically for other console drivers to run on OpenBSD systems. The options are in particular:
The “WSCOL_XXX” arguments are colors as defined in /usr/include/dev/wscons/wsdisplayvar.h. “WS_KERNEL_COLATTR” and “WS_KERNEL_MONOATTR” are additional attribute flags used on color or monochrome displays, respectively. The arguments are defined in the same header file. Whether the attributes are supported or not depends on the actually used graphics adapter. These options are ignored by the “dumb” terminal emulation.
|April 24, 2016||OpenBSD-6.0|