|WSCONSCTL(8)||System Manager's Manual||WSCONSCTL(8)|
wsconsctl — get or
set wscons state
wsconsctl command displays or sets
various wscons system driver variables. If a list of variables is present on
the command line,
wsconsctl prints the current value
of those variables for the specified device.
The options are as follows:
=’ symbol, or as a relative value, by using the ‘
+=’ symbol. See the EXAMPLES section for more details.
wsconsctl utility can be used to view
and modify aspects of the keyboard, display, and mouse using the standard,
machine-independent workstation console device driver
The keyboard type can be modified, the keyboard bell's pitch, period, and duration can be modified, the typematic value can be changed, and the keyboard encoding can be modified to switch keys, should the user find a keyboard's default layout difficult to use.
There are also definitions relating to video control and cursor control, which are not applicable to all display types, and to text emulation and graphics (mapped) modes.
Use the kbd(8) utility to determine which keyboard encodings are available for your country.
A keyboard mapping can also be specified in /etc/kbdtype.
Set a UK keyboard encoding:
# wsconsctl keyboard.encoding=uk
Modify the current keyboard encoding so that, when the Caps Lock key is pressed, the same encoding sequence as Left Control is sent. For a full list of keysyms, and keycodes, please refer to the /usr/include/dev/wscons/wsksymdef.h file.
# wsconsctl keyboard.map+="keysym Caps_Lock = Control_L"
Assign the Right Alt key to be the group modifier (layout is changed while the key is pressed):
# wsconsctl keyboard.map+="keycode 184=Mode_switch"
Assign the Right Control key to be the lock for the group modifier. The effect of Mode_Lock and Mode_switch is not mutually exclusive, to be consistent with Caps Lock and Shift behaviour.
# wsconsctl keyboard.map+="keycode 157=Mode_Lock"
Set a US keyboard encoding, with the Caps Lock and Left Control keys swapped. The .swapctrlcaps encoding does not work for all national keyboard encodings. For most purposes, the ability to set the value returned by the Caps Lock key is enough - see the previous example for details.
# wsconsctl keyboard.encoding=us.swapctrlcaps
Set the bell pitch to be 1200:
# wsconsctl keyboard.bell.pitch=1200
Add 200 to the current pitch of the bell:
# wsconsctl keyboard.bell.pitch+=200
wsconsctl command first appeared in
NetBSD 1.4 and OpenBSD
|August 4, 2008||OpenBSD-6.0|