|PING6(8)||System Manager's Manual||PING6(8)|
ping6 — send
ICMPv6 ECHO_REQUEST packets to network hosts
ping6 uses the ICMPv6 protocol's mandatory
ICMP6_ECHO_REQUEST datagram to elicit an
ICMP6_ECHO_REPLY from a host or gateway.
ICMP6_ECHO_REQUEST datagrams (“pings”)
have an IPv6 header, followed by an ICMPv6 header formatted as documented in
RFC 4443. The options are as follows:
ECHO_RESPONSEpackets. If count is 0, send an unlimited number of packets.
SO_DEBUGoption on the socket being used.
ECHO_REQUESTsent a period (‘.’) is printed, while for every
ECHO_REPLYreceived a backspace is printed. This provides a rapid display of how many packets are being dropped. Only the super-user may use this option.
ping6command does not try reverse-lookup unless the option is specified.
ping6sends that many packets as fast as possible before falling into its normal mode of behavior. Only the super-user may use this option.
ping6asks the kernel to fragment packets to fit into the minimum IPv6 MTU.
-mwill suppress the behavior in the following two levels: when the option is specified once, the behavior will be disabled for unicast packets. When the option is specified more than once, it will be disabled for both unicast and multicast packets.
This option is ignored if any of the flags
-tWw] are specified.
ping6 for fault isolation, it
should first be run on the local host, to verify that the local network
interface is up and running. Then hosts and gateways further and further
away can be “pinged”. Round-trip times and packet loss
statistics are computed. If duplicate packets are received, they are not
included in the packet loss calculation, although the round trip time of
these packets is used in calculating the round-trip time statistics. When
the specified number of packets have been sent (and received) or if the
program is terminated with a
SIGINT, a brief summary
is displayed, showing the number of packets sent and received, and the
minimum, maximum, mean, and standard deviation of the round-trip times.
This program is intended for use in network testing, measurement,
and management. Because of the load it can impose on the network, it is
unwise to use
ping6 during normal operations or from
ping6 will report duplicate and damaged
packets. Duplicate packets should never occur when pinging a unicast
address, and seem to be caused by inappropriate link-level retransmissions.
Duplicates may occur in many situations and are rarely (if ever) a good
sign, although the presence of low levels of duplicates may not always be
cause for alarm. Duplicates are expected when pinging a broadcast or
multicast address, since they are not really duplicates but replies from
different hosts to the same request.
Damaged packets are obviously serious cause for alarm and often
indicate broken hardware somewhere in the
packet's path (in the network or in the hosts).
The (inter)network layer should never treat packets differently depending on the data contained in the data portion. Unfortunately, data-dependent problems have been known to sneak into networks and remain undetected for long periods of time. In many cases the particular pattern that will have problems is something that does not have sufficient “transitions”, such as all ones or all zeros, or a pattern right at the edge, such as almost all zeros. It is not necessarily enough to specify a data pattern of all zeros (for example) on the command line because the pattern that is of interest is at the data link level, and the relationship between what is typed and what the controllers transmit can be complicated.
This means that if there is a data-dependent problem, a lot of
testing will probably have to be done to find it. It may be possible to find
a file that either cannot be sent across the network or that takes much
longer to transfer than other similar length files. This file can then be
examined for repeated patterns that can be tested using the
ping6 exits 0 if at least one reply is
received, and >0 if no reply is received or an error occurred.
ping6 works just like
ping(8) would work; the
following will send ICMPv6 echo requests to dst.foo.com:
$ ping6 -n dst.foo.com
The following will send ICMPv6 echo requests to the link-local all-node multicast address. The packet reaches all nodes on the network link attached to the wi0 interface.
$ ping6 ff02::1%wi0
A. Conta, S. Deering, and M. Gupta, Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification, RFC 4443, March 2006.
The ping(8) command
first appeared in 4.3BSD. The
ping6 command with IPv6 support first appeared in
the WIDE Hydrangea IPv6 protocol stack kit.
ping6 is intentionally separate from
|October 25, 2015||OpenBSD-6.0|