|RC.CONF(8)||System Manager's Manual||RC.CONF(8)|
rc.conf.local — system
daemon configuration database
rc.conf contains a series of
variable assignments that are used to configure the system daemons. These
variables are read by rc(8) early
on in the boot sequence and every time an
rc.d(8) script is executed.
It is advisable to leave
untouched, and instead create and edit a new
rc.conf.local file. Since only the last assignment
to any variable takes effect, variables set in this file override variables
previously set in
rc.conf is made up of variable assignments
(variable=value) with comments
designated by a hash mark (‘#’).
Base system daemon configuration variables are used to enable and disable daemon programs that are installed by default, and to set their command line options.
All of these variables follow the format “daemon_flags” where daemon is the name of one of the rc.d(8) daemon control scripts. The list of base system daemons, including the information whether they are enabled by default, can be displayed with this command:
grep _flags /etc/rc.conf
If one of these variables is set to
the respective daemon is disabled. If set to the empty
string, the daemon is run with the default command
line arguments defined in its
daemon script, or without command line arguments if no
such default exists. If set to any other value, including a string
containing only a single blank character, the daemon
is run with those command line arguments.
pkg_scripts variable lists
daemon control scripts to be started in the specified
order. For each daemon listed, its default command
line options can optionally be overridden using the variable
daemon_flags as described above.
Base system service configuration variables
control features available by default that are not implemented as daemons.
They can be set to either
NO. When set to
have the following effects:
-bin front of any other configured command line arguments when running spamd(8) and spamd-setup(8).
Auxiliary configuration variables mostly determine the locations of specific configuration files. The boot scripts use them as follows:
Do not start the dhcpd(8) daemon when booting the system:
To run the dhcpd daemon, add the following line to
To start it with some options:
Run /etc/rc.d/messagebus then
/etc/rc.d/cupsd with the
start argument at boot time, and in reverse order
stop argument at shutdown:
The default location of the amd(8) master map file is:
amd_master=/etc/amd/master # AMD 'master' map
rc.conf file first appeared in
|May 4, 2015||OpenBSD-5.8|