|QUOTACHECK(8)||System Manager's Manual||QUOTACHECK(8)|
filesystem quota consistency checker
quotacheck examines each filesystem,
builds a table of current disk usage, and compares this table against that
recorded in the disk quota file for the filesystem. If any inconsistencies
are detected, both the quota file and the current system copy of the
incorrect quotas are updated (the latter only occurs if an active filesystem
is checked). By default, both user and group quotas are checked.
-aflag is supplied in place of any filesystem names,
quotacheckwill check all the filesystems indicated in /etc/fstab to be read-write with disk quotas. By default, only the types of quotas listed in /etc/fstab are checked.
quotacheckreports discrepancies between the calculated and recorded disk quotas.
-u is equivalent to the default. Parallel passes are
run on the filesystems required, using the pass numbers in
/etc/fstab in an identical fashion to
quotacheck operates silently.
quotacheck expects each filesystem to be
checked to have quota files named quota.user and
quota.group located at the root of the associated
file system. These defaults may be overridden in
/etc/fstab. If a file is not present,
quotacheck will create it.
quotacheck accesses the raw device in
calculating the actual disk usage for each user. Thus, the filesystems
checked should be quiescent while
quotacheck command appeared in
|August 15, 2009||OpenBSD-5.8|