|RC.D(8)||System Manager's Manual||RC.D(8)|
rc.d — daemon
The /etc/rc.d directory contains shell scripts to start, stop, and reconfigure daemon programs (“services”).
Services installed from packages(7) may be started at boot time in the order specified by the pkg_scripts variable from rc.conf(8); the order will be reversed during shutdown. Services comprising OpenBSD base are started by rc(8).
The options are as follows:
startaction. It will forcibly start the daemon whatever value daemon_flags is set to. If daemon_flags is set to “NO”, execution will continue with the script's own defaults unless other flags are specified.
Each such script responds to the following actions:
start(only if rc_bg is set),
reloadactions to return. This is only guaranteed with the default
To obtain the actual variable names, replace daemon with the name of the script. For example, postgres is managed through /etc/rc.d/postgresql:
daemon_flags=-w -l /var/postgresql/logfile
To override this and increase the debug log level (keeping the existing flags), define the following in rc.conf.local(8):
postgresql_flags=-w -l /var/postgresql/logfile -d 5
Each script may define its own defaults, as explained in rc.subr(8).
daemon_class is a special read-only
variable. It is set to “daemon” unless there is a login class
login.conf(5) with the
same name as the
rc.d script itself, in which case
it will be set to that login class.
The /etc/rc.d directory first appeared in OpenBSD 4.9.
|February 25, 2015||OpenBSD-5.8|