|RC.SHUTDOWN(8)||System Manager's Manual||RC.SHUTDOWN(8)|
Firstly it saves random data for reseeding the kernel random
number generator during the next boot. It then stops any daemons defined in
the pkg_scripts variable in
passing them the
rc(8) then runs
rc.shutdown. The administrator should place in this
file any commands they wish to have executed during shutdown.
Finally, all carp(4)
interfaces are brought down and then the system shuts down. If
rc.shutdown has the variable
powerdown set to “YES”, the machine will
attempt to power off after it has halted.
If init(8) is exiting single-user mode it will also run the first part of shutdown (saving random data), though not the latter.
|July 8, 2011||OpenBSD-5.1|