|RC.D(8)||System Manager's Manual||RC.D(8)|
rc.d — daemon
The /etc/rc.d directory contains shell scripts to start, stop, and reconfigure daemon programs (“services”).
Services installed from packages(7) may be started at boot time in the order specified by the pkg_scripts variable from rc.conf(8); the order will be reversed during shutdown. Services comprising OpenBSD base are started by rc(8).
The options are as follows:
Each such script responds to the following actions:
To obtain the actual variable names, replace daemon with the name of the script. For example, postgres is managed through /etc/rc.d/postgresql. To run the daemon using a site-specific user account, define the following in rc.conf.local(8):
Each script may define its own defaults, as explained in rc.subr(8).
daemon_class is a special read-only
variable. It is set to “daemon” unless there is a login class
login.conf(5) with the
same name as the
rc.d script itself, in which case
it will be set to that login class.
The /etc/rc.d directory first appeared in OpenBSD 4.9.
|October 9, 2011||OpenBSD-5.1|