|BGPD(8)||System Manager's Manual||BGPD(8)|
bgpd — Border
Gateway Protocol daemon
bgpd is a Border Gateway Protocol (BGP)
daemon which manages the network routing tables. Its main purpose is to
exchange information concerning “network reachability” with
other BGP systems.
bgpd uses the Border Gateway
Protocol, Version 4, as described in RFC 4271. Please refer to that document
for more information about BGP.
bgpd is usually started at boot time, and
can be enabled by setting the following in
The options are as follows:
bgpdto do carp(4) demotion at startup when the demote functionality is used. Normally,
bgpdwill only do demotion at startup when the demotion counter for the group in question is already greater than 0.
bgpdwill start handling demotion after all sessions with demotion configured for the given group have been successfully established. At system startup, rc(8) has the demotion counter for the group carp increased until after
bgpdis started, so this option should not be used in rc.conf(8).
bgpdwill run in the foreground and log to stderr.
A Border Gateway Protocol 4 (BGP-4), RFC 4271, January 2006.
BGP Communities Attribute, RFC 1997, August 1996.
Protection of BGP Sessions via the TCP MD5 Signature Option, RFC 2385, August 1998.
Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing, RFC 2545, March 1999.
BGP Route Reflection - An Alternative to Full Mesh IBGP, RFC 2796, April 2000.
Route Refresh Capability for BGP-4, RFC 2918, September 2000.
The Generalized TTL Security Mechanism (GTSM), RFC 3682, February 2004.
NOPEER Community for Border Gateway Protocol, RFC 3765, April 2004.
BGP Extended Communities Attribute, RFC 4360, February 2006.
BGP/MPLS IP Virtual Private Networks (VPNs), RFC 4364, February 2006.
BGP Cease Notification Message Subcodes, RFC 4486, April 2006.
Multiprotocol Extensions for BGP-4, RFC 4760, January 2007.
BGP Support for Four-octet AS Number Space, RFC 4893, May 2007.
Capabilities Advertisement with BGP-4, RFC 5492, February 2009.
Error Handling for Optional Transitive BGP Attributes, draft-ietf-idr-optional-transitive-00, April 2009.
Subcodes for BGP Finite State Machine Error, draft-ietf-idr-fsm-subcode-02, August 2011.
MRT routing information export format, draft-ietf-grow-mrt-17, August 2011.
bgpd program first appeared in
|September 17, 2011||OpenBSD-5.1|