|NMEA(4)||Device Drivers Manual||NMEA(4)|
nmea — NMEA 0183
This line discipline interfaces NMEA devices, such as GPS receivers attached to a serial or USB port.
The line discipline is enabled by the following sequence:
#include <sys/ioctl.h> int ldisc = NMEADISC, fildes; ... ioctl(fildes, TIOCSETD, &ldisc);
The byte stream is unaltered by the line discipline which maintains timedelta and position sensors using the NMEA data. The sensors will appear as nmea* in the list. The timedelta (nanoseconds difference between the received time information and the local time), position (calculated latitude and longitude in degrees), altitude and speed can be accessed through the sysctl(8) interface.
nmea line discipline decodes the
following NMEA 0183 sentences:
Messages source are recognised by the first two characters of the NMEA sentence according to the following prefixes:
The quality of the timedelta is reported as the sensor status:
The status of a second sensor is used to report the status of the device itself:
nmea interface first appeared in
nmea line discipline was written by
|January 27, 2019||OpenBSD-current|