|NTPD(8)||System Manager's Manual||NTPD(8)|
ntpddaemon synchronizes the local clock to one or more remote NTP servers or local timedelta sensors.
ntpdcan also act as an NTP server itself, redistributing the local time. It implements the Simple Network Time Protocol version 4, as described in RFC 5905, and the Network Time Protocol version 3, as described in RFC 1305. Time can also be fetched from TLS HTTPS servers to reduce the impact of unauthenticated NTP man-in-the-middle attacks. The options are as follows:
ntpdwill run in the foreground and log to stderr.
ntpdwill stay in the foreground for up to 15 seconds waiting for one of the configured NTP servers to reply.
ntpdto send DEBUG priority messages to syslog.
ntpduses the adjtime(2) system call to correct the local system time without causing time jumps. Adjustments of 32ms and greater are logged using syslog(3). The threshold value is chosen to avoid having local clock drift thrash the log files. Should
ntpdbe started with the
-voption, all calls to adjtime(2) will be logged. After the local clock is synchronized,
ntpdadjusts the clock frequency using the adjfreq(2) system call to compensate for systematic drift.
ntpdis started at boot time by default via ntpd_flags in /etc/rc.conf. See rc(8) and rc.conf(8) for more information on the boot process and enabling daemons. When
ntpdstarts up, it reads settings from its configuration file, typically ntpd.conf(5), and its initial clock drift from /var/db/ntpd.drift. Clock drift is periodically written to the drift file thereafter.
ntpdprogram first appeared in OpenBSD 3.6.
|September 6, 2017||OpenBSD-current|