OpenBSD manual page server

Manual Page Search Parameters

BOOT(9) Kernel Developer's Manual BOOT(9)

boothalt or reboot the system

#include <sys/reboot.h>

void
boot(int howto);

The () function handles final system shutdown, and either halts or reboots the system. The exact action to be taken is determined by the flags passed in howto and by whether or not the system has finished autoconfiguration.

If the system has finished autoconfiguration, () does the following:

  1. Sets the boothowto system variable from the howto argument.
  2. If this is the first invocation of boot() and the RB_NOSYNC flag is not set in howto, syncs and unmounts the system disks by calling () and sets the time of day clock by calling resettodr(9).
  3. Disables interrupts.
  4. If rebooting after a crash (i.e., if RB_DUMP is set in howto, but RB_HALT is not), saves a system crash dump.
  5. Prints a message indicating that the system is about to be halted or rebooted.
  6. If RB_HALT is set in howto, halts the system. Otherwise, reboots the system.

If the system has not finished autoconfiguration, () prints a message, and halts the system (unless RB_USERREQ is specified, in which case the system will be halted if RB_HALT is given, and rebooted otherwise; see reboot(2) for more details).

reboot(2), resettodr(9)

December 10, 2014 OpenBSD-current