OpenBSD manual page server

Manual Page Search Parameters

BOOT(8) System Manager's Manual (luna88k) BOOT(8)

boot, boot.confluna88k-specific bootstrap

The main purpose of this program is to load the system kernel.

As described in boot_luna88k(8), this program is loaded by the luna88k ROM monitor and provides a convenient way to load the kernel. This program acts as an enhanced boot monitor for luna88k systems, providing a common interface for the kernel to start from.

Basic operations include:

The sequence of its operation is as follows: initialization, parsing the configuration file, then an interactive command line. While at the command line you have 5 seconds to type any commands, if needed. If time expires, the kernel will be loaded according to the current variable settings (see the set command). Each time a kernel load fails, the timeout is increased by one second. The sequence of boot operations is as follows:

  1. If the file /etc/boot.conf exists on the filesystem boot was loaded from, open and parse it. Lines beginning with the ‘#’ character, as well as whitespace at the beginning of lines, are ignored. The file may contain any commands boot accepts at the interactive prompt. Though default settings usually suffice, they can be changed here.
  2. The header line

    >> OpenBSD/luna88k BOOT [x.xx]

    is displayed to the active console, where x.xx is the version number of the boot program, followed by the

    boot>

    prompt, which means you are in interactive mode and may enter commands. If you do not, boot will proceed to load the kernel with the current parameters after the timeout period has expired.

By default, boot attempts to load the kernel executable /bsd. If it fails to find the kernel and no alternative kernel image has been specified, the system will be unable to boot.

The following commands are accepted at the boot prompt:

[[device:]image] [-acds]
Boots the specified kernel image with any options given. If device or image are omitted, values from boot variables will be used.

Available devices are:

sd(d,l,p)
SCSI device number d, logical unit number l, and partition p. The last two arguments can be omitted, in which case they will have a default value of zero. The encoding of the device number will match the encoding used by the ROM: devices numbered 0 to 6 on the first SCSI controller will use numbers 6 to 0, and devices numbered 0 to 6 on the second SCSI controller (on Luna88k-2 systems only) will use numbers 16 to 10.
le()
Onboard Ethernet.
Causes the kernel to ask for the root device to use.
Causes the kernel to go into boot_config(8) before performing autoconf(4) procedures.
Causes the kernel to drop into ddb(4) at the earliest convenient point.
Causes the kernel to boot single-user.
[args]
Displays args on the console device.
Prints a list of available commands.
addr size
Show size bytes of memory at address addr.
[directory]
Prints contents of the specified directory in long format including: attributes and file type, owner, group, size, filename.
Reboots the machine by initiating a warm boot procedure.
[varname [value]]
If invoked without arguments, prints a list of variables and their values. If only varname is specified, displays contents of that variable. If varname and value are both specified, sets that variable to the given value. Variables include:

Debug flag if boot was compiled with DEBUG defined.
Boot device name (e.g., sd(6,0)).
Options to pass to the loaded kernel.
File name containing the kernel image.
Number of seconds boot will wait for human intervention before booting the default kernel image.

/usr/mdec/boot
system bootstrap
/etc/boot.conf
system bootstrap's startup file
/bsd
kernel image
/bsd.sp
kernel image for single processor machines
/bsd.mp
kernel image for multiprocessor machines
/bsd.rd
kernel image for installation/recovery

Boot the default kernel:

boot> boot

Remove the 5 second pause at boot-time permanently, causing boot to load the kernel immediately without prompting:

# echo "boot" > /etc/boot.conf

Boot the kernel named /bsd from the SCSI disk with ID 2 in “User Kernel Configuration” mode (see boot_config(8)). This mechanism allows for the explicit enabling and disabling of devices during the current boot sequence, as well as the modification of device parameters. Once booted, such changes can be made permanent by using config(8)'s -e option.

boot> boot sd(4):/bsd -c

autoconf(4), ddb(4), boot_config(8), boot_luna88k(8), reboot(8)

This program was written by Michael Shalayeff for OpenBSD 2.1 on the i386 platform, and was later ported to the luna88k platform.

February 23, 2023 OpenBSD-current