|BOOT(8)||System Manager's Manual (landisk)||BOOT(8)|
— landisk-specific second-stage bootstrap
The main purpose of this program is to load the system kernel from the root file system of the machine.
This program is loaded by the xxboot(8) primary bootstrap loader and provides a convenient way to load the kernel. This program acts as an enhanced boot monitor for landisk systems, providing a common interface for the kernel to start from.
Basic operations include:
The sequence of its operation is as follows: initialization,
parsing the configuration file, then an interactive command line. While at
the command line you have 5 seconds to type any commands, if needed. If time
expires, the kernel will be loaded according to the current variable
settings (see the
set command). Each time a kernel
load fails, the timeout is increased by one second. The sequence of
boot operations is as follows:
bootwas loaded from, open and parse it. Lines beginning with the ‘#’ character, as well as whitespace at the beginning of lines, are ignored. The file may contain any commands
bootaccepts at the interactive prompt. Though default settings usually suffice, they can be changed here.
>> OpenBSD/landisk BOOT [x.xx]
is displayed to the active console, where
x.xx is the version number of the
boot program, followed by the
prompt, which means you are in interactive mode and may enter
commands. If you do not,
boot will proceed to
load the kernel with the current parameters after the timeout period has
boot attempts to load the
kernel executable /bsd. If it fails to find the
kernel and no alternative kernel image has been specified, the system will
be unable to boot.
The following commands are accepted at the
bootvariables will be used.
The only bootable device, at the moment, is the internal IDE device (either a compactflash media or an ATA disk drive), and is named ‘cf’. Therefore, to boot kernel /bsd from the internal drive, specify “boot cf:/bsd”.
bootwas compiled with DEBUG defined.
Boot the default kernel:
Remove the 5 second pause at boot-time permanently, causing
boot to load the kernel immediately without
# echo "boot" > /etc/boot.conf
Boot the kernel named /bsd.rd in
“User Kernel Configuration” mode (see
boot_config(8)). This mechanism
allows for the explicit enabling and disabling of devices during the current
boot sequence, as well as the modification of device parameters. Once
booted, such changes can be made permanent by using
boot> boot cf:/bsd.rd -c
This program was written by Michael Shalayeff for OpenBSD 4.1.
|December 23, 2019||OpenBSD-current|