|BWI(4)||Device Drivers Manual||BWI(4)|
bwi* at cardbus?
bwi* at pci?
bwidriver provides support for Broadcom AirForce based PCI/Cardbus network adapters.
These are the modes the
bwi driver can
bwi driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and
WPA2-PSK). WPA is the current encryption standard for wireless networks. It
is strongly recommended that WEP not be used as the sole mechanism to secure
wireless communication, due to serious weaknesses in it. The
bwi driver relies on the software 802.11 stack for
both encryption and decryption of data frames.
The transmit speed is user-selectable or can be adapted automatically by the driver depending on the received signal strength and on the number of hardware transmission retries.
A prepackaged version of the firmware can be installed using fw_update(1).
|Apple Airport Extreme||BCM4306||PCI||b/g|
|Apple Airport Extreme||BCM4318||PCI||b/g|
|Compaq R4035 onboard||BCM4306||PCI||b/g|
|Linksys WPC54G Ver 3||BCM4318||CardBus||b/g|
|Linksys WPC54GS Ver 2||BCM4318||CardBus||b/g|
|US Robotics 5411||BCM4318||CardBus||b/g|
# ifconfig bwi0 scan
The following hostname.if(5) example configures bwi0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
bwidriver first appeared in OpenBSD 4.3.
bwidriver was written for DragonFly by Sepherosa Ziehau and ported to OpenBSD by Jonathan Gray and Marcus Glocker.
|February 15, 2014||OpenBSD-6.1|