|IFMEDIA(4)||Device Drivers Manual||IFMEDIA(4)|
ifmediainterface provides a consistent method for querying and setting network interface media and media options. The media is typically set using the ifconfig(8) command.
Currently these link types are supported by
The following sections describe the possible media settings for each link type. Not all of these are supported by every device; refer to your device's manual page for more information.
The lists below provide the possible names of each media type or option. The first name in the list is the canonical name of the media type or option. Additional names are acceptable aliases for the media type or option.
The following media options are shared by all link types:
The following media options are defined for Ethernet:
The following media options are defined for FDDI:
The following media options are defined for IEEE802.11 Wireless LAN:
The following media modes are defined for IEEE802.11 Wireless LAN:
The channels detailed below are defined for IEEE802.11 Wireless LAN. The list of available frequencies is dependent on radio regulations specified by regional authorities. Recognized regulatory authorities include the FCC (United States), ETSI (Europe), France, and Japan. Frequencies in the table are specified in MHz.
Note that the channels do overlap; the bandwidth required for each channel is about 20MHz. When using multiple channels in close proximity it is suggested that channels be separated by at least 25MHz. In the US, this means that only channels 1, 6, and 11 may be used simultaneously without interference.
The following media options are defined for TDM:
By default TDM interfaces will use Cisco HDLC encoding with a 32-bit CRC checksum.
The following media modes are defined for TDM:
ifmediainterface first appeared in BSD/OS 3.0. The implementation that appeared in NetBSD 1.3 was written by Jonathan Stone and Jason R. Thorpe to be compatible with the BSDI API. It has since gone through several revisions which have extended the API while maintaining backwards compatibility with the original API.
Support for the IEEE802.11 Wireless LAN link type was added in NetBSD 1.5.
Host AP mode was added in OpenBSD 3.1.
|January 12, 2016||OpenBSD-6.1|