|ZIC(8)||System Manager's Manual||ZIC(8)|
zic — time zone
zic reads text from the file(s) named on
the command line and creates the time conversion information files specified
in this input. If a filename is
-”, the standard input is read.
These options are available:
zicwill act as if the input contained a link line of the form
Link timezone localtime
zicwill act as if the input contained a link line of the form
Link timezone posixrules
zic) appears in the input.
Input lines are made up of fields. Fields are separated from one another by any number of whitespace characters. Leading and trailing whitespace on input lines is ignored. An unquoted sharp character (#) in the input introduces a comment which extends to the end of the line the sharp character appears on. White space characters and sharp characters may be enclosed in double quotes (") if they're to be used as part of a field. Any line that is blank (after comment stripping) is ignored. Non-blank lines are expected to be of one of three types: rule lines, zone lines, and link lines.
Names (such as month names) must be in English and are case insensitive. Abbreviations, if used, must be unambiguous in context.
A rule line has the form:
Rule NAME FROM TO TYPE IN ON AT SAVE LETTER/S
Rule US 1967 1973 - Apr lastSun 2:00 1:00 D
The fields that make up a rule line are:
-” then the rule applies in all years between FROM and TO inclusive. If TYPE is something else, then
zicexecutes the command
yearistype year type
to check the type of a year: an exit status of zero is taken to mean that the year is of the given type; an exit status of one is taken to mean that the year is not of the given type.
Names of days of the week may be abbreviated or spelled out in full. Note that there must be no spaces within the ON field.
where hour 0 is midnight at the start of the day, and hour 24 is midnight at the end of the day. Any of these forms may be followed by the letter w if the given time is local “wall clock” time, s if the given time is local “standard” time, or u (or g or z) if the given time is universal time; in the absence of an indicator, wall clock time is assumed.
-” the variable part is null.
A zone line has the form:
Zone NAME GMTOFF RULES/SAVE FORMAT [UNTILYEAR [MONTH [DAY [TIME]]]]
Zone Australia/Adelaide 9:30 Aus CST 1971 Oct 31 2:00
The fields that make up a zone line are:
UNTILYEAR [MONTH [DAY [TIME]]]
The next line must be a “continuation” line; this has the same form as a zone line except that the string “Zone” and the name are omitted, as the continuation line will place information starting at the time specified as the “until” information in the previous line in the file used by the previous line. Continuation lines may contain “until” information, just as zone lines do, indicating that the next line is a further continuation.
A link line has the form:
Link LINK-FROM LINK-TO
Link Europe/Istanbul Asia/Istanbul
The LINK-FROM field should appear as the NAME field in some zone line; the LINK-TO field is used as an alternate name for that zone.
Except for continuation lines, lines may appear in any order in the input.
Lines in the file that describes leap seconds have the following form:
Leap YEAR MONTH DAY HH:MM:SS CORR R/S
Leap 1974 Dec 31 23:59:60 + S
The YEAR, MONTH, DAY, and HH:MM:SS fields tell when the leap second happened. The CORR field should be “+” if a second was added or “-” if a second was skipped. The R/S field should be (an abbreviation of) “Stationary” if the leap second time given by the other fields should be interpreted as UTC or (an abbreviation of) “Rolling” if the leap second time given by the other fields should be interpreted as local wall clock time.
Here is an extended example of
intended to illustrate many of its features.
# Rule NAME FROM TO TYPE IN ON AT SAVE LETTER/S Rule Swiss 1940 only - Nov 2 0:00 1:00 S Rule Swiss 1940 only - Dec 31 0:00 0 - Rule Swiss 1941 1942 - May Sun>=1 2:00 1:00 S Rule Swiss 1941 1942 - Oct Sun>=1 0:00 0 Rule EU 1977 1980 - Apr Sun>=1 1:00u 1:00 S Rule EU 1977 only - Sep lastSun 1:00u 0 - Rule EU 1978 only - Oct 1 1:00u 0 - Rule EU 1979 1995 - Sep lastSun 1:00u 0 - Rule EU 1981 max - Mar lastSun 1:00u 1:00 S Rule EU 1996 max - Oct lastSun 1:00u 0 - # Zone NAME GMTOFF RULES FORMAT UNTIL Zone Europe/Zurich 0:34:08 - LMT 1848 Sep 12 0:29:44 - BMT 1894 Jun 1:00 Swiss CE%sT 1981 1:00 EU CE%sT Link Europe/Zurich Switzerland
In this example, the zone is named Europe/Zurich but it has an alias as Switzerland. Zurich was 34 minutes and 8 seconds west of GMT until 1848-09-12 at 00:00, when the offset changed to 29 minutes and 44 seconds. After 1894-06-01 at 00:00 Swiss daylight saving rules (defined with lines beginning with "Rule Swiss") apply, and the GMT offset became one hour. From 1981 to the present, EU daylight saving rules have applied, and the UTC offset has remained at one hour.
In 1940, daylight saving time applied from November 2 at 00:00 to December 31 at 00:00. In 1941 and 1942, daylight saving time applied from the first Sunday in May at 02:00 to the first Sunday in October at 00:00. The pre-1981 EU daylight-saving rules have no effect here, but are included for completeness. Since 1981, daylight saving has begun on the last Sunday in March at 01:00 UTC. Until 1995 it ended the last Sunday in September at 01:00 UTC, but this changed to the last Sunday in October starting in 1996.
For purposes of display, "LMT" and "BMT" were initially used, respectively. Since Swiss rules and later EU rules were applied, the display name for the timezone has been CET for standard time and CEST for daylight saving time.
For areas with more than two types of local time, you may need to use local standard time in the AT field of the earliest transition time's rule to ensure that the earliest transition time recorded in the compiled file is correct.
If, for a particular zone, a clock advance caused by the start of
daylight saving coincides with and is equal to a clock retreat caused by a
change in UTC offset,
zic produces a single
transition to daylight saving at the new UTC offset (without any change in
wall clock time). To get separate transitions use multiple zone continuation
lines specifying transition instants using universal time.
|February 16, 2015||OpenBSD-current|