|VWAKEUP(9)||Kernel Developer's Manual||VWAKEUP(9)|
vwakeup() function updates the number of outstanding I/O operations on the target vnode, stored in its v_numoutput field. If the target vnode has the
VBIOWAITflag set in its v_bioflag field and has no outstanding I/O operations remaining, a wakeup(9) is performed as well.
vwakeup() function must be called at
vwakeup() more times than the number of outstanding I/O operations will cause the system to panic(9).
|August 14, 2013||OpenBSD-current|