|PANIC(9)||Kernel Developer's Manual||PANIC(9)|
panic — Bring down
system on fatal error
function makes the OpenBSD system terminate. The
message fmt is a
printf(9) style format string. The
message is printed to the console (with a newline) and the location pointed
to by the global char pointer panicstr is set to the
address of the message text for retrieval from the OS core dump.
If the kernel debugger is installed, control is passed to it. Otherwise, an attempt is made to save a core dump of the OS to a configured dump device.
called twice (from the disk sync routines, for example) the system is
rebooted without syncing the disks.
panic() function does not return.
|May 16, 2021||OpenBSD-current|